It is necessary to use updated software for plugins to keep your system secure?

It is a general view that, if the web browsers are up to date, your computer is safe while surfing the web but now you cannot be assured about it. Even if you have an updated web browser, you may surf the web with software which is extremely vulnerable.

CTO of Qualys Mr. Wolfgang Kandek says that they have examined the updated web browsers of many a man but they have seen that in most of the cases the web browsers are vulnerable. It will provide chance to the attackers to control your system. They can get all the private information quite easily. The data which are vulnerable in the disk can be found easily and all the keystrokes can be easily monitored by them. Therefore, you will be completely insecure with your system.

updated software for pluginsAccording to the security experts the web browsers should be updated all the time. If any kind of new patch arrives the web browser should be immediately updated. However, the attackers are targeting those vulnerabilities which had to be patched some years ago. They are not targeting the current patches at all. Black Hole one of the exploit kits has already attached the vulnerabilities which should have been closed earlier. One of the patches of Oracle which has flaw in Java is affected by Black Hole.

Kandek said, “Most of the users who use popular browsers are facing the same kind of problem. As they are utilizing the software which has vulnerabilities, they are facing insecurity problems with their system.”

It is true that the extent of insecurity can differ from one web browser to other. However, it is true that all the web browsers are insecure. According to Kandek Apple Safari which is the best web browser has this problem too. 35 percent of their users can face the risk.

According to Kandek browsers are not the reason behind the attacks. According to him, most f the browser maker is trying their best to navigate the flaw. They have improved the situation a lot. Now, the users don’t have to remember by him about updating the software. According to him, the attackers are finding vulnerabilities in the plugins as those are not always updated by the users.

By using plugins the browsers get additional capabilities to run a video or music. You can also play various games and can run various applications by the help of the plugins. These plugins are often attacked now by the attackers.

Qualys have analyzed the fact that most of the users of Java are using out of date version. Adobe flash player is another plugin, for which they have found that 67 percent people are using out of date versions. There are other plugins also the versions used of which are out of date. This is why the attackers are targeting the plugins now to control the systems and get data.

If the software of both the plugins and the browsers is updated with the newest software, the problem of vulnerabilities can be resolved easily.

Leave a Reply

It is necessary to use updated software for plugins to keep your system secure?

It is a general view that, if the web browsers are up to date, your computer is safe while surfing the web but now you cannot be assured about it. Even if you have an updated web browser, you may surf the web with software which is extremely vulnerable.

CTO of Qualys Mr. Wolfgang Kandek says that they have examined the updated web browsers of many a man but they have seen that in most of the cases the web browsers are vulnerable. It will provide chance to the attackers to control your system. They can get all the private information quite easily. The data which are vulnerable in the disk can be found easily and all the keystrokes can be easily monitored by them. Therefore, you will be completely insecure with your system.

updated software for pluginsAccording to the security experts the web browsers should be updated all the time. If any kind of new patch arrives the web browser should be immediately updated. However, the attackers are targeting those vulnerabilities which had to be patched some years ago. They are not targeting the current patches at all. Black Hole one of the exploit kits has already attached the vulnerabilities which should have been closed earlier. One of the patches of Oracle which has flaw in Java is affected by Black Hole.

Kandek said, “Most of the users who use popular browsers are facing the same kind of problem. As they are utilizing the software which has vulnerabilities, they are facing insecurity problems with their system.”

It is true that the extent of insecurity can differ from one web browser to other. However, it is true that all the web browsers are insecure. According to Kandek Apple Safari which is the best web browser has this problem too. 35 percent of their users can face the risk.

According to Kandek browsers are not the reason behind the attacks. According to him, most f the browser maker is trying their best to navigate the flaw. They have improved the situation a lot. Now, the users don’t have to remember by him about updating the software. According to him, the attackers are finding vulnerabilities in the plugins as those are not always updated by the users.

By using plugins the browsers get additional capabilities to run a video or music. You can also play various games and can run various applications by the help of the plugins. These plugins are often attacked now by the attackers.

Qualys have analyzed the fact that most of the users of Java are using out of date version. Adobe flash player is another plugin, for which they have found that 67 percent people are using out of date versions. There are other plugins also the versions used of which are out of date. This is why the attackers are targeting the plugins now to control the systems and get data.

If the software of both the plugins and the browsers is updated with the newest software, the problem of vulnerabilities can be resolved easily.

Scroll to top